IRCE in Chicago
Join us at booth 1637
More info
XC4 to XC5 Migration wizard (Beta)

XC4 to XC5 Migration wizard (Beta)

  • Free
    Compatible: 5.3.0.x - 5.3.4.x
Don’t see your version? Contact us
Author: X-Cart team
Installations: 963
Rating:
(2)
Score: 3.5 (votes: 2)
Previous image
XC4 to XC5 Migration wizard (Beta)
Next image
Zoom image

The module guarantees trouble-free migration from X-Cart 4 (version 4.4.0 or later) to X-Cart 5. It transfers data and settings, and as a result, you get a working store on a new platform within a few minutes. So, afterwards, you only have to change the look and feel and make some additional minor settings according to your business.

Key features

  • Migration of the store data
    The wizard allows migrating
    • categories,
    • products (with attributes and extra fields),
    • product variants,
    • eGoods and the products' file attachments,
    • market price for products,
    • wholesale pricing for products,
    • users, customers and customer memberships,
    • menu,
    • static pages (some static pages are not possible to migrate though),
    • 'contact us' page,
    • languages (the wizard will advise on the translation addons you need to install),
    • orders,
    • bestsellers,
    • featured products,
    • related products,
    • reviews.

      You just need to select the stuff for migration;

  • Migration of the store settings
    To help you avoid time-consuming store setup after switching to X-Cart 5, the wizard can transfer your store settings: 
    • payment methods (AuthorizeNet, Moneybookers, PayPal, TwoCheckout, eWay), 
    • shipping methods (AP, CPC, DHL, Fedex, UPS, USPS),
    • zones.

  • Missing add-ons check
    The wizard checks if the set of features in your new X-Cart 5 store matches the one in your old X-Cart 4 store. If it finds missing tools and integrations, you get a list of X-Cart 5 modules that need to be enabled or purchased. Besides, it partially migrates the addons settings.
Average rating:
(2)
Score: 3.5 (votes: 2)
Please to add review
  • Anthony York
    Feb 3, 2017, 13:38
    This module should have a system requirements area as you can't migrate from anything earlier than v4.4.
    So anyone wishing to go from 4.1.10 for example, will need to upgrade to 4.1.12 and then again to 4.5.0 then install a fresh X-Cart v4.5.0 store with the upgraded database. You can also upgrade the fresh X-Cart installation to a newer version (for example 4.5.0 -> 4.6.0 -> 4.7.0 -> 4.7.7).
    Its not "a few minutes" process.
    Good luck!